BindEm

MegaPirate X

2,920 posts in this topic

вариант не подошёл

Я сдаюсь :( Как правильно, так и неправильно отображаемые надписи в программе имеют одинаковый шрифт и кодировку. Отличий ноль. Почему новому детищу микрософт вздумалось печатать по-разному то же самое, ума не приложу.

Пользуйте англ. версию.

Share this post


Link to post
Share on other sites

Поздравляю всех с Днем защитника отечества - 23 февраля!!!

В честь праздника, тем у кого компас выдает не правильное значение, вместо пены для бритья и носков дарю информацию к размышлению.

Обратите внимание на близкое расположение крепежного отверстия и компаса на плате MPX.

post-84-0-07400200-1456214073_thumb.jpg

 

Если для крепежа платы MPX Вы использовали болт или шуруп из "черного" металла (в добавок возможно намагниченный отверткой), то этот "черный" металл сильно искажает показания компаса. Вполне возможно, что при длительном воздействии такой "черный" металл  может вывести микросхему компаса из строя.

smg2000 and rattis like this

Share this post


Link to post
Share on other sites

Вот я и думаю: для чего везде где можно стараюсь использовать пластиковые винты и гайки )))

Share this post


Link to post
Share on other sites
тем у кого компас выдает

 

Всех с праздником!
У меня плата "пришпилена" обрезанными бамбуковыми шпажками. Несмотря на это, при старте компас не выходит "куда надо".

После "танцев с бубном", вернее, после пары-тройки оборотов самолета по всем осям перед стартом, компас показывает более чем правильное направление. Это уже вошло в привычку как своеобразный ритуал, все нормально.

Но если плата привернута железными винтиками, конечно, проблем будет больше.

Share this post


Link to post
Share on other sites

У меня плата "пришпилена" обрезанными бамбуковыми шпажками.

 

Интересно. Какие еще без магнитные способы крепления придумали пользователи платы MPX.

Share this post


Link to post
Share on other sites

Гаоздями прибить, изолентой примотать, проволочкой.

Вприантов много :)

Share this post


Link to post
Share on other sites
болт или шуруп из "черного" металла (в добавок возможно намагниченный отверткой), то этот "черный" металл сильно искажает показания компаса

Вроде, неоднократно упоминалось Олегом, и в этой теме тоже, что "чёрным" крепежом фиксировать плату - себе дороже, в плане проблем с компасом.

 

без магнитные способы крепления

Самый основной, простой и надёжный - на двусторонний скотч. Достаточно двух полосочек шириной 8-10мм поперёк платы на всю ширину.

И никаких помех компасу :).

Edited by dundel1

Share this post


Link to post
Share on other sites

Олег, раз уж так получилось, что все замечательно с полетными характеристиками нашего любимого а/п, попробуем устранить обидные мелочи.

Нумбер уан. Если включить АП с отсоединенным датчиком ВС, при следующем ШТАТНОМ включении воздушная скорость будет определяться как 231 км/ч.

Не поможет и повторное включение. Только обнуление из контрольной панели.

Нельзя ли предусмотреть принудительный сброс датчика при старте системы? А то иногда на холоде работать с планшетом просто не реально. Тупо не реагирует экран.

А включать с отсоединенным датчиком в моем случае иногда приходится.

Датчик установлен в крыле, при отладке не всегда есть возможность крыло подсоединять.

Один раз не заметил и при взлете грохнул самолет. По понятной причине рули практически не работали.

Share this post


Link to post
Share on other sites

Разберемся. Намбер ту будет?

Edited by Syberian

Share this post


Link to post
Share on other sites

Да, но мне сейчас сложно сформулировать. Пятница (еще), поздний вечер ;)

Спасибо.

Share this post


Link to post
Share on other sites

Будет намбер "ту" - тоже самое с датчиком тока...

Share this post


Link to post
Share on other sites

Костя, ты часто включаешь АП с отсоединенным датчиком тока?

А вообще да, проблема есть. Кстати, в твоем случае после подсоединения датчик нужно заново калибровать.

Share this post


Link to post
Share on other sites

нет, но при включении ток 10-20 ампер а после сброса на ноль показывает правду..

Edited by Anothercat

Share this post


Link to post
Share on other sites

Господа разработчики, не пора ли обновить руководство?

А то нововведений за последнее время много накопилось.

По форуму искать описание - проблематично.

Strizh likes this

Share this post


Link to post
Share on other sites

Господа разработчики, не пора ли обновить руководство? А то нововведений за последнее время много накопилось. По форуму искать описание - проблематично.

 

 

Хорошо бы, чтобы в новой документации Adobe Reader версии 10 и выше  находил русские слова, а то в текущей версии документации Adobe Reader английские слова находит, а русские не находит. :(

Share this post


Link to post
Share on other sites

Тук-тук... Странности творятся с моим АП.. Не корректно определяет напряжение ВАТ1. Подключаю разряженную 4S меряю прибором 13.8в. выставляю в CGS. Подключаю заряженную - показывает 15,1. Как бысть?

Share this post


Link to post
Share on other sites
Если включить АП с отсоединенным датчиком ВС, при следующем ШТАТНОМ включении воздушная скорость будет определяться как 231 км/ч.

принято.

при включении ток 10-20 ампер а после сброса на ноль показывает правду..

Поясните.

Я правильно вас понял, что АП при включении каждый раз показывает ток 20 А и его приходится занулять? Или вы по неким причинам вынуждены включать АП без датчика тока, он начинает показывать х..ню и чтобы не мотал мА/ч до подключения датчика, его приходится занулять дважды?

 

А то нововведений за последнее время много накопилось.

Как мне кажется, глобального ничего не было, кроме замены КИ, но по нему отдельная инструкция.

Все изменения с момента последней инструкции описаны здесь: http://up.megapiratex.com/updates.txt

Пару фоток подправить, да текста немножко...

 

в новой документации Adobe Reader версии 10 и выше находил русские слова

Инструкция делалась в ворде и переводилась в ПДФ через ABBYY PDF Transformer 3.0. Что он там творит с кодировкой, ума не приложу. Могу отдельно выкладывать docx.

Не корректно определяет напряжение ВАТ1. Подключаю разряженную 4S меряю прибором 13.8в. выставляю в CGS. Подключаю заряженную - показывает 15,1. Как бысть?

1) Не питаться от комповского USB при калибровке, только rx, tx и земля.

2) а если подключить 2s или 3s, например, с балансирного разъема - тоже врет? А что мультиметр показывает на заряженной батарейке?

Share this post


Link to post
Share on other sites

 

при включении ток 10-20 ампер а после сброса на ноль показывает правду..

Поясните.

Я правильно вас понял, что АП при включении каждый раз показывает ток 20 А и его приходится занулять? Или вы по неким причинам вынуждены включать АП без датчика тока, он начинает показывать х..ню и чтобы не мотал мА/ч до подключения датчика, его приходится занулять дважды?

 

ТОЧНО..

 

 

Не корректно определяет напряжение ВАТ1. Подключаю разряженную 4S меряю прибором 13.8в. выставляю в CGS. Подключаю заряженную - показывает 15,1. Как бысть?

1) Не питаться от комповского USB при калибровке, только rx, tx и земля.

2) а если подключить 2s или 3s, например, с балансирного разъема - тоже врет? А что мультиметр показывает на заряженной батарейке?

 

 

Не питаюсь от USB, мультиметр на входе платы кажет 16.6. Приходится калибровать на посаженом и в полете ориентироваться на авось. 

Share this post


Link to post
Share on other sites

Инструкция делалась в ворде и переводилась в ПДФ через ABBYY PDF Transformer 3.0. Что он там творит с кодировкой, ума не приложу. Могу отдельно выкладывать docx.

 

Выкладывайте в docx, на сайте..

Share this post


Link to post
Share on other sites

В процессе создания скрипта не нашел функцию для получения текущей даты и времени (по Гринвичу) из данных GPS.

Если такой функции нет, то можно ли создать такую функцию?

Если есть возможность создать такую функцию, то не плохо было бы иметь настраиваемую в настройках константу - "Текущий часовой пояс".

Edited by Strizh

Share this post


Link to post
Share on other sites

Уважаемый Олег! SYberian!

Многое хочу сказать, но ... не знаю как.

более удачного решения АП нет. ..... Ну, летаем в общем, и будем летать!, т.к. само все летает.

Share this post


Link to post
Share on other sites
On 29.02.2016 at 13:10, Strizh said:

можно ли создать такую функцию?

Можно, добавим...

14 hours ago, rw9hk said:

Многое хочу сказать, но ... не знаю как.

Так и не понял, что у вас сломалось :D

Share this post


Link to post
Share on other sites

...

Edited by Syberian
дубль

Share this post


Link to post
Share on other sites

Вроде обнаружил ошибку в функции X_PTR_mode$

> AP_PTR_mode "PTR_HEAD"
> PRINT X_PTR_mode$
 1

Результат: PanTilt реагирует на команды пульта управления.

> AP_PTR_mode "PTR_OFF"
> PRINT X_PTR_mode$
 1

Результат: PanTilt НЕ реагирует на команды пульта управления.

Почему то функция X_PTR_mode$ - вместо строк "PTR_OFF" или "PTR_HEAD" всегда возвращает число 1.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now