Luka

PitLab (OSD + автопилот + наземка)

690 posts in this topic

7 минут назад, Plohish сказал:

никакого, комплект АП, ОСД, наземка, ну и естественно планшет андроид(программа платная!) или комп на винде, программа бесплатная.

Для удобства можно вместо кабеля для связи компа и наземки взять блютуз модуль...

Можно по подробней, автопилот+osd pitlab заказал недавно буду осваивать.

Наземка - это что-то конкретное, что там должно быть? 

Программа какая нужна?

Share this post


Link to post
Share on other sites
15 минут назад, alef сказал:

Можно по подробней, автопилот+osd pitlab заказал недавно буду осваивать.

Наземка - это что-то конкретное, что там должно быть? 

Программа какая нужна?

наземка это устройство

gs-obudowa2_320.jpg

вкратце это:

  • декодер телеметрии
  • устройство управления трекером  антенны
  • двухканальный диверсити сигнала видео
  • трёхканальный выход видео
  • логгер всей телеметрии с записью на карту памяти
  • ну и прочие мелкие функции

 

вот к этой коробочке и подключается планшет или ноут...

она же управляет антенным трекером если надо...

 

программа FPV_manager

или

FPV Tracker

https://play.google.com/store/apps/details?id=pl.com.bigaj.osd&hl=ru

Edited by Plohish

Share this post


Link to post
Share on other sites

В наземку получается видеосигнал подключаем, а она с него декодирует телеметрию или туда как-то отдельно телеметрия заводится?

Share this post


Link to post
Share on other sites
Только что, alef сказал:

В наземку получается видеосигнал подключаем, а она с него декодирует телеметрию или туда как-то отдельно телеметрия заводится?

да, всё правильно, она с него декодирует

Share this post


Link to post
Share on other sites

Классная штука, мне нравится

Share this post


Link to post
Share on other sites

Итак, перехожу на автопилот PitLab, начал установку в самолёт, разбираю пока что да как, возникло много вопросов, кое что сам понял разобрался, до чего-то пока не дошёл. Сейчас вопрос возник нужно ли плату как-то обрабатывать лаком или другими способами, она не имеет никакого корпуса, боюсь что туда рано или поздно попадёт вода, было уже у меня такое, черпанул снега однажды он конечно растаял, лужа стояла.

Share this post


Link to post
Share on other sites

по твоему желанию, только если будешь обрабатывать, не залей дырочку на датчике давления

я не делал ни на скае ни на мини талоне...

 

вопросы задавай тут, помогу

Share this post


Link to post
Share on other sites

Вот как раз боялся куда не надо залить лишнего

 

Share this post


Link to post
Share on other sites

Где тут датчик давления? Похоже на металический квадратик с дырочкой в углу возле синего разъема

image.jpeg

Share this post


Link to post
Share on other sites

да, это он

ну и разъёмы тоже не залей...

Share this post


Link to post
Share on other sites

Датчик тока правильно подключил? Что-то сдается мне, что не правильно, средний контакт не использовал.

Надо как-то это дело заизолировать потом, как это лучше сделать?

image.jpeg

 

Edited by alef

Share this post


Link to post
Share on other sites

у датчика есть вход есть выход, неужели трудно глянуть что на нём написано? :)

по моему я уже постил тут эту картинку...

28894051965_a150940052_b.jpg

 

средний контакт возле силовых проводов не используется...

 

заизолировать надо, мало ли куда может коротнуть... я в термоусадку затянул...

 

Share this post


Link to post
Share on other sites

Я наоборот припаял, тупанул, плохо смотрел надписи, перепаивать придётся.

Share this post


Link to post
Share on other sites

Опять вопрос по автовозврату, никак не получается добиться устойчивой работы. Как я уже писал раньше, иногда при включении автовозврата самолёт начинал летать по кругу и рядом с цифрами расстояния до базы появлялся значок со стрелкой (я так и не нашёл информации что это означает). Если этот значок не появлялся, то автовозврат работал как надо (приводил на базу, удерживал заданную высоту, нарезал круги). Какой- либо закономерности в появлении этого значка я не мог обнаружить, уже начал думать что попался бракованный экземпляр, хотел писать разработчикам потом потерял самолёт из-за некорректной работы возврата на базу, через неделю нашёл, уже летает. После такого непонятного поведения автовозврата, когда нашёл самолёт заново ещё раз тщательно настроил автопилот и оттримировал самолёт. Сегодня на свежей батарейке отлетаю на километр включаю возврат, опять появляется значок со стрелкой и самолет начинает нарезать круги. Погода была безветренная, батарейка свежая, решил подождать. Обратил внимание, что самолет набирает высоту достаточно активно. У меня в настройках стоит мин высота 160метров, ограничение по высоте 1000метров. Перешёл в стаб, набрал тысячу сто метров, включил автовозврат, и о чудо, ненавистный значок не появляется, самолёт полетел на базу, снизился до 160 метров и встал в круг. Пробую ещё раз, то же самое. Приземлился, выключил ограничение высоты в меню osd, взлетел, набрал метров 500включил автовозврат-работает на отлично. Больше не проверял, стемнело. Завтра продолжу. Но я не могу понять логику такой работы автовозврата, при чем здесь ограничение по высоте. Это у всех так работает, или я невнимательно читаю инструкции?

Share this post


Link to post
Share on other sites

Поведение АП абсолютно адекватное... Ты собственной рукой установил режим, в котором перед возвратом требуется немедленный подъём на установленную высоту, по этому ты видишь стрелку в начале возврата и кружение самолёта с подьемом... Он используется когда летаешь в гористой местности или с высокими препятствиями... Не мудрено что в попытке набрать 1000 метров с севшей батареей ты упал...

Установи другой режим в котором с текущей высоты сразу идёт автовозврат...

Edited by Plohish

Share this post


Link to post
Share on other sites

Датчик тока подсоединил, вроде работает, ток показывает, остаток батареи показывает, отсчёт ведёт от того значения, которое я указал в настройках. Хотелось бы узнать, можно ли поменять чтобы показывало сколько потратил, а не сколько осталось, у меня разные батареи, каждый раз лезть в настройки не удобно мне кажется. Сначала вообще показывало только индикатор батареи, нашёл в настройках галочку, индикатор убрал, стало цифрами казать

Share this post


Link to post
Share on other sites

Сергей, посмотрел у тебя на OSD все нормально показывает и потраченные амперы и индикатор сколько осталось, я не могу найти где там какие галочки поставить

Share this post


Link to post
Share on other sites

30166255322_25905c629f_b.jpg

 

и соответствующие поля "properties" в каждом...

Share this post


Link to post
Share on other sites

Эти поставил, а вот что в проперти ставить пока не разобрался

Share this post


Link to post
Share on other sites

неужели там всё так сложно?

там простые антгл слова перевод которых не так сложен в гугле:

power - энергия (ватты)

capacity (ёмкость)

remaining (обратное)

в совокупности с тем пунктом меню в котором ты лазишь по моему более чем понятно...

 

мне что теперь каждую галочку скринить? :)

спрашивай конкретно что не понятно, а не "я пока не разобрался..."

Share this post


Link to post
Share on other sites

Не злись, разобрался, все правильно делал, просто сделано по-польски. Потраченные амперы не показывает ничего даже 0 не кажет, пока не потратишь, я думал не работает или ещё где настройки есть. На газ жму, а ничего нет, потом появилось через некоторое время.

Share this post


Link to post
Share on other sites

по моему это очень логично ничего не показывать пока ничего не потрачено...

но там есть галка "Hide min" и она включена у тебя

как думаешь как переводится? :) 

Edited by Plohish

Share this post


Link to post
Share on other sites

А еще там есть галочки где черточки стоят, я не придираюсь, просто чтобы понять, надо нажать и сбегать посмотреть что изменилось.

Share this post


Link to post
Share on other sites

чёрточки без подписей это пустые поля, они ни на что не реагируют...

поля 

Black background

Inverted

Small font

сразу же отображают на что они действуют... но и без знаний англ по моему понятно для чего они...

Share this post


Link to post
Share on other sites

Ранее писал что сервы начали сами по себе дергаться. Перепаивал разные регули, и сервы ставил, не помогло. Поставил питание отдельным беком, сервы не дергаются, но гудят иногда. Странно, раньше летал без бека, все было нормально. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now